HP-UX

From Mesopoly 3.0
(Redirected from HP UX)
Jump to navigation Jump to search

This page is a byproduct of me getting ready for HP-UX CSA exam (hpo-091). It may split into more pages latter. I have previous knowledge of Linux, so what I point out here would be HPUX specifics and not neccesary basic and most relevant stuff.

I am making notes here as I go through CSA: Official Study Guide and Reference.

links

tips and notes

shell

  • misc
    • posix is default shell in hpux
    • rsh : restritcted shell
    • Key shell : key shell, context sensitive shell
  • files
    • .sh_history .profile controled by HISTFILE variable
  • commands
    • Line completition : Esc Esc
    • history use Esc+K to navigate, shows last 15 commands by default r fc
    • ulimit lock alias whoami who w logname uname getconf id banner cal stty ttytype jobs fg bg wait

shell programming

  • commands
    • shift read exit break continue
    • let or (( ))
    • test or [[ ]]
  • loops
    • for do done
    • while do done
    • until do done
  • variables
    • $? exit code from last program
    • $$ PID of the shell

files & directories

  • misc
    • file names can be 256 characters long
  • commands
    • cat more pg pr ls lsf file grep
  • syntax
    • mv file1 file2 dir/
    • find use for example with -name -size -atime -mtime -perm -type -exec
  • files
    • /etc/magic


I/O redirection

  • data streams - stdin stdout stderr
    • > standard output, file descriptor '1'
    • < standard input, file descriptor '0'
    • 2> standard error, file descriptor '2'
  • syntax
    • 2>&1| pipe stderr and stdout to ..
  • tee

environment variables

  • environment (global) and shell (local)
    • difference - environment variables are inherited from parent proccess (shell) ..
  • syntax
    • $ VARX=SomeValue
    • $ echo $VARX
    • $ VARX="$VARX addblah"
    • $ VARX=`command` (Bourne, POSIX)
    • $ VARX=$(command)
    • export VARX promotes shell variable to environment variable
  • commands
    • set unset alias whence export
  • misc
    • single quotations takes 'as is' value, not variable value
    • predefined (PATH HOME PWD SHELL TERM PS1 PS2 MANPATH TZ EDITOR LOGNAME)

file permissions

  • commands umask
  • misc
    • SETUID SETGID - to run exe file as user of file
  • syntax
    • chmod u+s file or chmod 2777 file for setting SETUID (4 for SETGID, 1 for Sticky Bit)

VI commands

I - insert at ther begginig of the line 3,404w file.txt write lines 3 to 404 to file.txt :m n move current line to after line n :t n copy current line to after line n

kernel reconfiguration

  • sysdef (and kmtune: shows tunable kernel parameters
  • cd /stand/build
  • /usr/lbin/sysadm/system_prep -s system - creates /stand/build/system as configuration file with parameters taken from running system
    • kmtune -S /stand/build/system - queries system for kernel parameters
    • kmsystem -S /stand/build/system - which modules would be in new kernel
    • kmtune -S /stand/build/system -s maxusers=30 - sample setting value of a parameter
    • kmsystem -S /stand/build/system -q ps2 - queries system file for the status of ps2 value
    • kmsystem -S /stand/build/system -c Y ps2 - changes value of ps2 to Yes
    • kmadmin
  • mk_kernel -s ./system - builds new kernel using system as configuration file. Creates file /stand/build/vmunix_test.
  • kmupdate - schedules movement of newly built vmunix_test to /stand/ on next reboot. Directory /stand/build/system/ has to be moved manually.

devices

  • types of files - regular files, directories, devices, links, sockets, named pipes
  • major and minor device number
    • major device number stands for driver used for device
    • minor device number is defined by physical location and device specifics..
  • character and block device
    • named character or raw device file
      • for serial data transfer
      • on ls -al first letter is c
    • block devices
      • moves blocks to buffer and writes after sync executed by syncer daemon
      • on ls -al first letter is b
  • device hardware address

c t d

  • mknod syntax

disks / file systems

  • pvdisplay
    • use block device file as argument
  • vgdisplay
    • uses volume group device as argument f.e. /dev/vg00
  • lvdisplay
    • uses logical volume block device as argument
  • mediainit
    • formats disk and confirms integrity. uses raw / character device file!
  • pvcreate
    • creates physical volume using raw device file
  • vgcreate - creating volume group
    • mknod /dev/vg02/group c 64 0x020000
    • vgcreate /dev/vg02 /dev/dsk/c2t5d0
  • vgextend
  • lvcreate
    • f.e. lvcreate -L 500 -n masopust vg02 creates logical volume of size 500mb named mosopust in volume group vg02
  • vgdisplay
  • lvextend
  • lvreduce
  • lvdisplay
  • extendfs - with Advanced JFS fsadm can be used without unmounting
  • vgscan - manages volumes in /etc/lvmtab
  • lvreduce pvchange pvremove vgremove vgreduce vgexport vgimport lvlnboot lvsplit lvmerge vgcfgbackup vgcfgrestore vxtunefs vxupgrade


  • metadata - superblock, inodes, directory area
  • fstyp
  • newfs
  • mount
  • fuser - manages processes / use of filesystem. Useful if you want to unmount filesystem.
  • bdf

backup

  • commands tar sfbackup/frecover dd

users management

  • id groups newgrp rsh pwck grpck vipws

processes

  • nice renice timex trap

printing

  • lp lpstat cancel lpalt rlpdaemon rmodel lpsched lpshut lpadmin accept LPDEST lpmove enable disable reject accept lpfence lpana

memory and swap

  • daemons swapper vhand
  • commands swapon swapinfo

automation

  • commands cron crontab at batch

performance and optimization

  • commands iostat vmstat netstat lanadmin top sar prmavail, Glance Plus UX, Perfview

LAN interface

network speed length cable repeaters
10BASE-2 ethernet 10 Mb/s 185m 50 Ohm thin coaxial 4
10BASE-5 ethernet 10 Mb/s 500m 50 Ohm thick coaxial
10BASE-T 10 Mb/s 100m twisted pair
100BASE-T 100 Mb/s 100m twisted pair
100VG-AnyLAN 100 Mb/s
1000BASE-T 1000 Mb/s 100m
  • terminology
    • DLPI - Data Link Provider Service
  • commands lsdev ioscan lanscan ifconfig netstat ndd linkloop
  • files /etc/rc.config.d/hpetherconf hpbtlanconf nddconf

Samba

  • commands smbclient smbstatus cifsmount ciflist

hpux recipes

  • hpux history When attempting to make use of history file I was presented with

sh: fc: Cannot access or open the history file.


To fix this file .profile has to be edited. Add following two lines.
HISTFILE=/.sh_history
export HISTFILE

HP-UX abbreviations

  • VSE - Virtual Server Environment

to do yet

  • cut
  • tee - sends output of pipe to additional place (file as well as stout f.e.)
  • 'hardware path'